Written by
Tim Brotherhood
and
Adam Haas

These materials are © 2012, Parametric Technology Corporation (PTC)
All rights reserved under copyright laws of the United States and other countries.

Conditions of use
Copying and use of these materials is authorized only in the schools colleges and universities of teachers who are authorized to teach Creo Parametric in the classroom.
All other use is prohibited unless written permission is obtained from the copyright holder.

Acknowledgements
Based on the work of several UK trainers, in particular Alan Patterson.
Proofing and comments – Curtis Siebenaller, Ayora Berry, Mark Fischer, Adam Haas, Myron Moss, Phil Walker.

Trialing materials -

Feedback
tbrotherhood@ptc.com
In order to ensure these materials are of the highest quality, users are asked to report errors to the author.
Suggestions for improvements and other activities would also be very welcome.

Product code  C2-SE-L1-004-1.0

Copyright © 2011 Parametric Technology Corporation. All Rights Reserved. Copyright for PTC software products is with Parametric Technology Corporation, its subsidiary companies (collectively “PTC”), and their respective licensors. This software is provided under written license agreement, contains valuable trade secrets and proprietary information, and is protected by the copyright laws of the United States and other countries. It may not be copied or distributed in any form or medium, disclosed to third parties, or used in any manner not provided for in the software licenses agreement except with written prior approval from PTC.

UNAUTHORIZED USE OF SOFTWARE OR ITS DOCUMENTATION CAN RESULT IN CIVIL DAMAGES AND CRIMINAL PROSECUTION.

User and training guides and related documentation from PTC is subject to the copyright laws of the United States and other countries and is provided under a license agreement that restricts copying, disclosure, and use of such documentation. PTC hereby grants to the licensed software user the right to make copies in printed form of this documentation if provided on software media, but only for internal/personal use and in accordance with the license agreement under which the applicable software is licensed. Any copy made shall include the PTC copyright notice and any other proprietary notice provided by PTC. Training materials may not be copied without the express written consent of PTC. This documentation may not be disclosed, transferred, modified, or reduced to any form, including electronic media, or transmitted or made publicly available by any means without the prior written consent of PTC and no authorization is granted to make copies for such purposes. Information described herein is furnished for general information only, is subject to change without notice, and should not be construed as a warranty or commitment by PTC. PTC assumes no responsibility or liability for any errors or inaccuracies that may appear in this document.
Contents

Contents ......................................................................................................................... 3
Introduction ..................................................................................................................... 5
Understanding the Creo Parametric interface ................................................................. 6
What’s new in Creo Parametric ...................................................................................... 9
Working directories and saving your work ................................................................... 10
  Working Directory Theory ....................................................................................... 10
  Opening Files .......................................................................................................... 11
  Saving Files ........................................................................................................... 11
Procedure – Part Modeling – Corner cube .................................................................... 12
  Step 1: Set working directory and create a new part ............................................. 13
  Step 2: Start an Extrude ....................................................................................... 15
  Step 3: Create a sketch to define the shape of the cube ........................................ 16
  Step 4: Complete the Extrude for the corner block .............................................. 20
  Step 5: Extrude the first hole ............................................................................... 25
  Step 6: Extrude the second hole .......................................................................... 29
  Step 7: Use the Hole tool to create the third hole ................................................ 34
  Step 8: Round edges of the cube ........................................................................ 38
  Step 9: Chamfer edges of the holes .................................................................... 41
Procedure – Part modeling - Strut ................................................................................ 44
  Step 1: Set working directory and create a new part ............................................. 45
  Step 2: Start an Extrude ....................................................................................... 47
  Step 3: Create a sketch to define the peg diameter ................................................. 48
  Step 4: Complete the Extrude that defines the length of the strut ....................... 50
  Step 5: Extrude shoulder geometry ..................................................................... 51
  Step 6: Revolve a sketched arc to thin the center of the strut ................................ 54
  Step 7: Round edges of the strut ........................................................................ 60
  Step 8: Chamfer the ends of the strut .................................................................. 62
Procedure – Assembly ................................................................................................. 64
  Step 1: Set working directory and create a new assembly ................................... 64
  Step 2: Adding the first component to the assembly ............................................. 66
  Step 3: Add the first strut to the assembly ............................................................. 69
  Step 4: Applying colors and textures to the parts ................................................ 75
  Step 5: Assembling more struts .......................................................................... 77
Procedure - Rendering .................................................................................................. 81
  Step 1: Open the Render tab and apply a scene ................................................... 81
Step 2: Draft render ................................................................................................... 85
Step 3: Adding perspective ....................................................................................... 86
Step 4: Render setup ................................................................................................ 87
Step 5: Final render ................................................................................................... 88

Procedure - Engineering drawing ................................................................................. 89
Step 1: Set working directory and open cube corner ................................................. 90
Step 2: New engineering drawing ............................................................................. 91
Step 3: Changing the drawing scale .......................................................................... 93
Step 4: Moving views ................................................................................................ 95
Step 5: Adding dimensions ........................................................................................ 96
Step 6: Adding annotations ....................................................................................... 99

Extension task ............................................................................................................ 101
Module 1

Introduction

This primer will introduce you to the modeling, visualization and design tools in Creo Parametric.

Creo Parametric is a leading 3D design program, used by many of the top product development companies in the world.

You will be taught how to use Creo Parametric to model two components for a construction kit - a cube and a strut.

You will then be shown how to put these together to form an assembly, create a photo-realistic rendered image and an engineering drawing.
Module 2
Understanding the Creo Parametric interface

The Main Creo Parametric interface looks like this.

Main Interface Theory
The Creo Parametric user interface is easy to navigate with the key tools for a particular task contained in the ribbon across the top of the graphics area. Key elements of the main interface include:

Quick Access Toolbar — Contains commonly used tools and functions.

Ribbon Tabs — A set of tabs across the top of the interface. The active tab displays a set of tools in the ribbon immediately below. Here the View tab is active.
**Graphics Area** — The working area of Creo Parametric in which you view, create, and modify models such as parts, assemblies, and drawings.

**Message Area** — The message area provides you with prompts, feedback, and messages from Creo Parametric. Messages are logged and can be scrolled or the message window dragged to display more lines.

**Dashboard** — Locked at the top of the graphics area, the Dashboard appears when you create or edit a feature.

- The Dashboard provides you with controls, inputs, status, and guidance for carrying out a task, such as creating or editing a feature. Changes are immediately visible in the graphics area.
- Tabs along the bottom of the Dashboard provide additional feature options.
- Dashboard icons on the left include feature controls while the Pause, Preview, Complete Feature or Component and Cancel Feature options are grouped right of the center.
Dialog Boxes — Content-sensitive windows that appear, displaying and prompting you for information.

Menu Manager — A cascading menu that appears on the far right during the use of certain functions and modes within Creo Parametric. You select options working from top to bottom in this menu; however, clicking “Done” works from bottom to top. Bold menu options will be automatically selected if the middle mouse button is clicked.
What’s new in Creo Parametric

To help existing CAD users, here is a list of the key changes in Creo Parametric 2.0

- Tabbed **ribbon menus** with 90% of the tools instantly available.
- **Customizable** ribbon interface.
- The new **Command Search** tool lets you type a command and see a filtered list of tools. When you cursor over an item in the list, Creo locates and highlights the command in the ribbon.
- **Learning Connector** provides short on-demand “How to” videos linked to each tool.
- New **Shading with Edges** display type.
- Starting a feature like extrude lets you select the sketch plane without seeing the sketch dialog box. Much simpler and now the quickest (CAD program) on the draw!
- While sketching, holding down the ALT key lets you create **references on-the-fly** without interrupting the sketch tool.
- **Construction** mode in sketcher.
- The new **Center Rectangle** tool lets you sketch a rectangle from its center.
- Enhanced geometry **colors** to help visualization and selection.
- **Freestyle** is a new subdivision modeler in Creo Parametric. Freestyle is similar to Warp but much more powerful and very easy to use. Take a look at the vacuum cleaner **demo** on YouTube.
- **Dynamic Edit** - Direct access to features and parameters with real time regeneration.
- **3D Dragger** handles make editing and positioning really easy.
- **Automatic** addition (protrusion) or removal (cut) of material when creating Extrude or Revolve features.
- Extrude with **taper** or draft applied to the side surfaces of the extruded geometry.
- New, easy to use **Corner Chamfer** tool.
- Single **sweep** command combines variable section and simple sweep tools.
- Single **helical sweep** tool now offers variable section and variable pitch.
- Streamlined and enhanced **measurement** tools.
- Enhanced **sheet metal** tools including live flat pattern preview.
- Creo Parametric will open native Solidworks, Inventor and Solid Edge models making it easy to **reuse legacy data** when upgrading to Creo.
- Faster **assembly**, real time **interference** detection and easier 3D **sections**.
Working directories and saving your work

The Working Directory is the location for opening files from and saving new files to.

Setting your Working Directory:

- Creo Parametric is started in a default working directory.
- The working directory is set before every session. When you exit Creo, it does not remember the working directory for the next session.

Open Files - The File Open dialog box looks first in the working directory.

Save Files - Files are saved to the folder they were opened from, this is not always the working directory.

Working Directory Theory

The working directory is the designated location for opening and saving files. The default working directory is the “Start in” location defined in the Creo Parametric start icon properties, typically “My Documents” or your “home” drive or folder on a network.

If you are not using PTC’s Windchill PDMLink to manage your Creo Parametric data, it is best practice to organize your work by creating a folder for each project. Each time you start Creo Parametric, you should set the working directory to the folder you plan to work in. In this course you will be instructed to create a folder and set that as your working directory.

There are four methods to set your working directory, use the method you are most comfortable with:

- From the Home tab - When Creo Parametric first opens, Click Select Working Directory from the Data group of the Home tab. Browse to locate the directory you wish to use, open it and click OK. This is the easiest and most straightforward method.

- From the File menu – If the Home tab is not available - Click File> Manage Session> Select Working Directory. Browse to the location that is to be the new working directory, select it and click OK.

- From the Creo Parametric Folder Tree or Browser - Right-click the folder that is to be the new working directory and select Set Working Directory from the pop-up menu.
From the Creo Parametric **File Open** dialog box - Right-click the folder that is to be the new working directory and select **Set Working Directory** from the pop-up menu.

You can browse directly to the working directory at any time by selecting Working Directory in the folder view of the Navigator panel on the left of the Creo window.

### Opening Files

After you have set your working directory, you will see the files in that folder each time you click **Open** in Creo Parametric. You can use any of the following methods to open a file:

- Click **File > Open** from the main menu, click **Open** from the Quick Access toolbar or click **Open** from the Home tab. Then, in the **File Open** dialog box, you either double-click the file you want to open or select the file and click **Open**.
- Browse to the desired folder using the Navigator to display its contents in the browser. Then, you either double-click the file you want to open or, right-click the file in the browser and select **Open** from the pop-up menu.
- Drag a file from the browser into the graphics area.

The File Open dialog box is the equivalent of the Navigator and Browser combination in the main interface.

### Saving Files

By default, files are saved to the folder they were opened from. A new part, assembly, or drawing will be saved to the folder that is active when you click **OK** from the Save Object dialog box. You can use any of the following methods to save a file:

- Click **File > Save** from the File menu.
- Click **Save** from the Quick Access toolbar.
- Use the **CTRL + S** keyboard shortcut.

**What have you learned?**

- The layout of Creo Parametric’s user interface
- Interface items such as the Dashboard, dialog boxes, and the ribbon interface
- Working directories and file management
Procedure – Part Modeling – Corner cube

Scenario
This section will teach you how to model a cube shaped corner block for a construction kit.

You will create a new part, start an extrude, add a square sketch, and use this to extrude the cube shape.

Extruded circles will be used to create two of the holes and the Hole tool will be used for the third hole.

Rounds on the outer corners and chamfers on the holes will complete the model.
Task 1: Set working directory and create a new part

1. Start Creo Parametric.

2. In the **Home** tab, **Data** group, click **Select Working Directory**.

3. In the Select Working Directory dialog box
   - Navigate to the folder where you want to store your construction kit components. We suggest that you create a new folder (right-click and select **New Folder** from the pop-up menu) for each project you work on.
   - After you have browsed into the working directory folder, click **OK** to set that folder as your working directory.

   ![Image](image.png)

   The Corner Cube part you create will be saved to, and opened from, this “working directory”.

4. Creating the new corner cube part model:
   - From the Quick Access toolbar or **Home** tab, click **New**.
   - In the New dialog box, notice the default object Type is **Part** and Sub-type is **Solid**; these are the correct options for creating a solid part.
   - Type **CORNER_CUBE** in the **Name** field and click **OK**.

   ![Image](image.png)

   You cannot use spaces in filenames so use underscores or hyphens instead.
5. Changing the display of datum features:
   - In the Graphics toolbar at the top of the graphics area, disable the display of all datum features except datum planes.

Think of datum planes as the framework your model will be built on.

Datum planes have a front or positive surface and back or negative surface.

The frame showing the placement of each datum plane is colored **brown** when viewed from the front (positive side) and **gray** when viewed from the rear (negative) side.

**What have you learned?**

- Setting working directories and starting new parts.
- Controlling the display of datum features
- Datum plane theory
Step 2: Start an Extrude

The easiest way to start creating solid geometry in Creo Parametric is to begin a 3D feature, in this case an extrude, then select the sketch plane. Extrude is just one of the "sketch based" features in Creo Parametric.

You will start an **Extrude** then select datum plane **FRONT** as your sketching plane.

1. Starting an Extrude (sketched) feature and defining the sketch plane:
   - Start the **Extrude** tool from the **Shapes** group of the **Model** tab.

   While using Creo Parametric, keep an eye on the prompt line at the bottom of the screen. There you will see messages telling you what Creo is doing, if there is a problem or what you need to do next. In this case you are being guided to select the sketch plane.

   ![Select a sketch. (If an internal sketch is preferred, the "Define" option can be found in the Placement panel.)](image)

   - In the model tree or the graphics area, select datum plane **FRONT**.

   The Sketch tab will open and you will be able to start sketching. Two “Reference” lines will be visible on the Front datum plane.

   ![A sketch needs a minimum of two Reference lines to locate the geometry you create. In this case, Creo Parametric has created these automatically based on the other two datum planes.](image)

What have you learned?

- Starting an Extrude (sketched) feature.
- Selecting a sketch plane.
- The Ribbon interface workflow.
Step 3: Create a sketch to define the shape of the cube

A 2D, 30 mm square will be sketched on datum plane FRONT. The square will be drawn symmetrical about the intersection of the reference lines using a Center Rectangle tool. You will add an equal length constraint on two adjacent sides of the square.

1. Toggle off the display of datum planes:
   • In the Graphics toolbar, disable the display of all datum features.

2. Sketching the rectangle:
   • In the Sketch tab, select Center Rectangle from the Rectangle types drop-down menu.
   • In the Graphics toolbar, click Sketch View to reorient the sketch plane parallel to the screen.

The model space will rotate until the sketch plane is parallel to the computer screen.
   • Move the cursor over the intersection of the two reference lines at X1, when the cursor snaps to the intersection, click to set the center of the rectangle.
   • Move the cursor diagonally and click X2 to set a corner of the rectangle.
   • Middle-click in the graphics area to deselect the rectangle tool.
Sketches are controlled by two types of parametric constraints.

**Dimension constraints** allow you to alter sizes. Later you will use dimensions to define the size of this rectangle.

**Geometric constraints** including; equal length, parallelism, perpendicular, coincident, and so on. Creo has already applied many of these while you were sketching the square; to keep lines vertical/horizontal and make lines pass through the origin. Next, to change this rectangle to a square, you will apply an equal length constraint.

3. Adding an “Equal Length” skinner constraint:

You will add an Equal Length geometric constraint between two adjacent sides of the rectangle to make it a square. Creo Parametric is smart enough to remove one of the blue-gray (weak) dimensions to avoid over constraining the sketch.

- Click X1 to select the top horizontal line in the rectangle. The line should change color to **green** to show it is selected.

- Press and hold **CTRL** on the keyboard, then click X2 to add the vertical line to the selection. This line will also change color to **green**.

- With both lines selected, right-click and select **Equal** from the pop-up menu (shown as X3).

Notice that one of the blue-gray “weak” dimensions has disappeared and a pair of **L1** (Equal Length) constraints have appeared next to the selected lines.
There should now be just one dimension on the sketch. This is called a “weak” dimension and it is displayed in a blue-gray color. Sketch dimensions are “parametric” meaning when you change them the geometry will change to match the new value. You will change the dimension to 30 and lock it.

4. Changing a dimension to 30:
   - Move the cursor over the dimension value shown here at X1, and double-click.
   - Type the new value of 30 and then press ENTER.
   - Click in a blank area of the graphics window to de-select the dimension.

The size of the square will change according to the new dimension value. You have just seen parametric control in action.
   - If necessary, click Refit from the Graphics toolbar. This will refit the sketch in the graphics area.

The position and size of sketch lines are controlled by a combination of dimension constraints and geometric constraints.

Notice that the dimension changed to a blue color, showing that it is now a strong dimension.

Sketch geometry controlled by weak or strong dimensions can still be dragged. To fix dimensions so they cannot change accidentally, they must be locked.

5. Locking a dimension
   - Click to select the dimension. It turns green to show it is selected.
   - Right-click and hold on the selected dimensions and from the pop-up menu, select Lock.
   - Click in blank area of the graphics window to de-select the dimension
The dimension will now be colored **brown** to show it is locked.

6. Reorient the model to its default orientation:
   - Press **CTRL + D** (on the keyboard, hold down the **CTRL** key and press **D**).

You will now see a preview of the extruded square sketch.

7. Click **OK** from the **Close** group of the **Sketch** tab to complete the sketch and return to the Extrude dashboard.

**What have you learned?**

- Creating sketch geometry - center rectangles.
- Geometric constraints – overview, apply equal length.
- Dimension constraints, changing, weak, strong and locked.
- Viewing the model – default, flat sketch view and refit.
- Datum display - visibility.
- Dashboard interface.
Step 4: Complete the Extrude for the corner block

You will now edit the depth of the Extrude to be 30, extruding equally in both directions from the sketch plane so that the datum planes are at the center of the cube; this will be helpful when locating the holes later in this exercise. Extrude is a sketch based feature and this example used an “Internal” sketch.

1. If necessary, use the Graphics toolbar to disable the display of all datum features.

You can change how the extrude is defined either in the dashboard or on the model. Every element that defines the Extrude feature can be accessed from the dashboard.

After a feature is complete, you can use Edit Definition to re-open the dashboard and edit the feature.
2. Making changes to the extrude using the dashboard:

- In the extrude dashboard, click on the small triangle next to the depth option \( X_1 \) to open the drop-down menu. Select **Symmetric** from the list.
- Click in the depth field \( X_2 \), type **30** and press **ENTER**.
- Click **Complete Feature** from the dashboard.
- In the Graphics toolbar, click to refit the model in the graphics screen.

The new extrude feature is added to the Model Tree on the left of the screen.

3. Saving your work

- In the Quick Access toolbar, click **Save**.
- In the **Save Object** dialog, click **OK** to specify that the model will be saved to your working directory.

If the extrude dashboard mysteriously closes before intended, you probably middle mouse clicked. Engineers use many shortcuts to speed up their work and middle click is the shortcut to select **Complete Feature** and close the dashboard!

- If you need to re-open the dashboard, right-click on **Extrude 1** in the model tree and select **Edit Definition** from the pop-up menu.
What have you learned?

- Datum display - visibility.
- Viewing the model – Default orientation.
- Extrude – Remove material (cut), symmetric and through all.
- Dashboard to define and edit feature options.
- Edit features in the graphics area.
- Model Tree – stores features.
- Edit Definition to re-open and change existing features.
Dynamic Viewing

The orientation of your model within the graphics area is easily controlled using the mouse and the Graphics toolbar.

### 3D mode

- Spin
- Pan + Shift
- Zoom
- Turn + Ctrl

### 2D and 3D mode

- Zoom
- Fine Zoom + Shift
- Course Zoom + Ctrl

### 2D mode

- Pan
- Zoom + Ctrl

---

It is possible to ‘lose’ the model from the graphics area by spinning or panning the model completely out of the display. If your model ever disappears from the window, click **Refit** from the Graphics toolbar or press **CTRL + D**.
Graphics Toolbar
The Graphics toolbar at the top of the graphics area controls how the model appears in the graphics area.

Experiment with the options to see the effect they have on the appearance of the model.
Step 5: Extrude the first hole

Instead of adding material, the extrude tool can also be used to remove material, in this case we use an extruded cut that is shaped like a circle.

This extrude feature will be created by sketching an 8 mm diameter circle on the front face of the cube. The extrude will remove material and intersect the entire cube.

1. If necessary, use the Graphics toolbar to disable the display of all datum features.

2. Starting an Extrude (sketch based) feature and defining the sketch plane:
   - Start the Extrude tool from the Shapes group of the Model tab.

3. Starting an internal sketch:
   - Press CTRL + D to reorient the model.
   - In the graphics area, click to select the front face of the cube X1, as the sketch plane.
     The Sketch tab will open and you will be able to start sketching immediately.
   - To make sketching easier while you are learning, click Sketch View from the Graphics toolbar; this will reorient the sketch plane parallel to the computer screen.
4. Sketching a circle:
   - Click **Center and Point circle** from the Sketching group of the Sketch tab.
   - Move the cursor until it snaps to the intersection of the reference lines \(X_1\), and click to locate the center of the circle.
   - Move the cursor away from the center and click at \(X_2\) to complete the circle.
   - Middle-click in the graphics area to deselect the circle tool.
   - Double-click the diameter dimension value \(X_1\), then type 8 and press **ENTER**.
   - Click in a blank area of the graphics window to deselect the dimension.

The circle will resize and the dimension will change color to show it is now **strong**.

5. Reorient the model to its default orientation:
   - Press **CTRL + D** to reorient the model.
   - Click **OK** from the **Close** group of the **Sketch** tab to complete the sketch and return to the Extrude dashboard.
By default, Creo Parametric will display a preview of the extruded circle, adding material, away from the model.

- Drag the drag handle (small white square) away from the model to add depth to the feature.
- Drag the drag handle the other direction, into the model to reverse its direction.

Notice that Creo Parametric is smart enough to know that extruding into the model requires material to be removed (a cut).

In the Extrude dashboard at the top of the graphics area, you will see that the Remove Material (X2) icon has been automatically enabled.

6. Experiment with extrude dashboard controls.

- Click **Change Depth Direction** (X1) to toggle the extrude direction.
- Click **Remove Material** (X2) to toggle between adding and removing material.
7. Defining the extruded (cut) circle.
   • Set the direction into the model.
   • Remove materials should be selected.
   • Select Through All (X3) from the depth drop-down menu, so that the extrude feature will intersect the entire model.
   • Press the middle mouse button and drag to spin the model and see that the extrude feature intersects the entire model.
   • In the dashboard, click **Complete Feature** to complete the extrude feature.
   • A second extrude feature is added to the model tree on the left of the screen.

8. Saving your work:
   • Press **CTRL + D** to reorient the model.
   • In the Quick Access toolbar, click **Save**.

**What have you learned?**
   • Viewing the model – default, refit, 3D orientation, spin, pan, zoom, 2D pan and zoom.
   • Graphics toolbar – menu options.
   • Datum display – visibility.
   • Extrude – removing material (cut), changing direction and intersect with all surfaces.
   • Sketch – On surface, dashboard, center and point circle, dimension, lock dimension.
   • Dashboard to define and edit feature options.
   • Edit features in the graphics area.
   • Edit definition to re-open and edit existing features.
   • Saving the model.
Step 6: Extrude the second hole

You will use the technique used in Step 5, to extrude another 8 mm diameter cut. This time, the circle will be sketched on the right side of the cube.

1. Starting an Extrude feature and defining the sketch plane:
   - Start the **Extrude** tool from the **Shapes** group of the **Model** tab.

2. If necessary, disable the display of all datum features.

3. Starting an internal sketch:
   - If necessary, press **CTRL + D** to reorient the model.
   - In the graphics area, click to select the right side of the cube X1, as the sketch plane.

The Sketch tab will open, presenting you with all of the sketching tools.
This time leave the model in default orientation while sketching the circle.
Look carefully and you will see two light blue “Reference lines”. One passes through the center of the sketch plane but the other along the back edge.

To easily locate the center of the circle at the center of the cube, you will create another reference using datum plane FRONT.

You could create this reference before sketching by clicking References from the Setup group of the Sketch tab. It can also be created on-the-fly while sketching.

4. Enable the display of datum planes.

5. Creating a reference “on-the-fly”, while sketching a circle:
   - Click Center and Point circle from the Sketching group of the Sketch tab.
   - Press and hold the ALT key and move the cursor over datum plane FRONT (X1). When the datum plane pre-highlights in green, click to select it as a sketcher reference.
   - Release the ALT key and a new light blue reference line is created coincident with the FRONT datum plane.
• Move the cursor until it snaps to the intersection of both reference lines in the center of the sketch plane and click \((X1)\) to place the center of the circle.
• Move the cursor away from the center and click at \(X2\) to complete the circle.
• Middle-click in the graphics area to deselect the circle tool.

6. Edit the diameter of the circle:
   • Double click the diameter dimension value \(X1\), then type 8 and press ENTER.

The circle will resize as soon as you press ENTER.

7. Click OK ✅ from the Close group of the Sketch tab to complete the sketch and return to the Extrude dashboard.

8. Disable the display of all datum features.
9. To flip the direction of the feature, click the small purple direction arrow (X1).

Notice that when the extrude direction was flipped into the model Remove Material was automatically enabled (X1).

10. Edit the depth of the extrude to intersect the entire model.
   - From the depth drop-down menu, select Through All (X2) so that the extrude feature will intersect the entire model.
   - Spin the model to see that the extrude feature intersects the entire model.
   - In the dashboard, click Complete Feature.
• The new Extrude feature is added to the bottom of the model tree.

11. Saving your work:
   • In the Quick Access toolbar, click **Save**.

- Accepting default names for features is fine for simple models like this. Complex models can have hundreds of features making it difficult to find a particular feature in the model tree to make edits.

- It’s good practice to give key features recognizable names. Features can be renamed when they are being created or by clicking twice on the text in the model tree, making sure to pause between clicks.

**What have you learned?**

- Default orientation.
- Renaming feature names.
- References, specifying references on-the-fly while sketching geometry.
- Sketcher – Internal sketch, center and point circle and dimension.
- Extrude – internal sketch, remove material, changing direction and intersect with all surfaces.
- Saving the model.
Step 7: Use the Hole tool to create the third hole

Creo Parametric’s Hole tool is an “engineering” feature meaning it doesn’t rely on a sketch to define its shape. The placement of a hole feature can be defined in many different ways. This hole will be placed on the top surface of the cube and then located using two align constraints from datum planes FRONT and RIGHT.

1. Reorient the model to its default orientation:
   - Press **CTRL + D** to change to the Default Orientation.

2. Enable the display of only datum planes.

3. Creating a hole feature:
   - Start the Hole tool from the Engineering group of the Model tab.
   - Notice the Hole dashboard and the feature options.

   - Click to select the top surface of the model, shown in green.
   - Notice the preview of the hole feature is at the location you selected on the surface.

4. Viewing the model from the top
   - In the graphics toolbar, open the Named Views list and select TOP.
The square white drag handles control the location of the center, diameter and depth of the hole.

The green diamonds are offset reference handles and control the location of the hole’s center relative to where the diamonds are placed.

You will drag the green diamonds onto the RIGHT and FRONT datum planes to use these as references for the location of the hole center.

5. Locating the hole using offset reference handles:
   - Drag one of the green offset reference handles X1, to datum plane FRONT, when the plane pre-highlights, release the mouse button.
   - Drag the other offset reference handle X2 onto datum plane RIGHT.

It is easy snap a drag handle onto the wrong reference. If this happens, either click **Undo** or drag the handle to the intended reference.

You will now see dimensions between each datum plane and the center of the hole.

To locate the hole at the center of the cube, you could edit both linear dimensions to be zero but a better method is to change the offset references from a dimension value to Align.
• Open the Placement tab from the bottom-left of the dashboard X1.

• In the Offset References section of the Placement tab X2, click Offset from one of the references and select Align from the drop down menu.

• Edit the other Offset reference to also be Align.

• Click on the Placement tab to close it.

Notice that because the center of the hole is now aligned to the FRONT and RIGHT datum planes, the offset dimensions have been removed.
You will now use the dashboard to define the diameter and depth of the hole.

6. Defining the diameter and depth for the hole in the dashboard:

• Edit the hole diameter X1 to be 8 and press ENTER.

• Select Through All X2 from the depth drop-down menu, so that the hole will intersect the entire model.

You have completed the definition of an 8 mm thru hole; located at the center of the cube.

• Spin the model to see that the hole intersects the entire model.

• Click Complete Feature.

7. Saving your work:

• Click Save.
What have you learned?

- Engineering feature – Hole, dimension references
- Default Orientation
- Hole reference – model surface
- Hole placement - offset from datum planes and changing offset to align.
- Hole dashboard – diameter and intersect with all surfaces.
- Saving the model.
Step 8: Round edges of the cube

The Round feature is an “engineering” type feature applied to edges of a model. You will now add a 5 mm radius round to the twelve outside edges of the cube.

1. Press **CTRL + D** to reorient the model.

2. If necessary, disable the display of all datum features.

3. Edit the model display style to be **Hidden Line**:
   - In the Graphics toolbar, select **Hidden Line** from the Display Style drop-down menu.

This display style will make it easier for you to see edges at the back of the model.
4. Start the Round tool from the Engineering group of the Model tab.
   • Notice the Round dashboard and the feature options.

5. Defining the radius of the round:
   • In the dashboard, edit the radius $X_1$ to be 5 and press ENTER.

6. Selecting the edges to round:
   • Click to select one of the edges shown in green.
   • Press CTRL and select the remaining 11 edges shown in green.
   - If you select an edge by accident, keep the CTRL key held down and click the edge again to de-select.
   - If you need to re-open the round dashboard, right-click the Round 1 feature in the model tree and select Edit Definition from the pop-up menu.

7. Click Complete Feature to complete the round.
8. Changing the display style and saving your work:
   • In the Graphics toolbar, select **Shading with Edges** from the Display Style types drop-down menu.

9. Saving your work
   • Click **Save** to save your work.

**What have you learned?**

- Engineering feature – Round.
- Round dashboard - radius.
- Selecting edge references – individual, adding more edges with CTRL key.
- Rotating the model.
- Edit Definition to re-open and edit existing features.
- Saving the model.
Step 9: Chamfer edges of the holes

The Chamfer feature is an “Engineering” type feature applied to edges of a model. You will now add 0.5 mm chamfers to the six edges of the holes that intersect the outer surfaces of the cube.

1. Press **CTRL + D** to reorient the model.

2. If necessary, disable the display of all datum features.

3. Start the **Chamfer** tool from the **Engineering** group of the **Model** tab.
   - Notice the Chamfer dashboard and its feature specific options.

4. Defining the size of the chamfer:
   - In the dashboard, edit the chamfer width **X1** to be **0.5** and press **ENTER**.

5. Selecting the edges to chamfer:
   - Click to select one of the edges shown in **green**.
   - Press **CTRL** and select the other two edges shown in **green**.
6. Spinning the model to select more edges:
   - Release the CTRL key.
   - Spin the model to see the three edges that have not been selected.

   If you middle-click but do not hold down the middle-mouse and move it to spin the model, the feature will complete with only the first three edges selected and the dashboard will close.

   To re-open the dashboard and select the remaining edges, right-click Chamfer 1 from the model tree and select Edit Definition from the pop-up menu.

7. Selecting the remaining edges:
   - Press CTRL and select the remaining edges.

8. Completing the chamfer:
   - Click Complete Feature… to complete the chamfer.
   - Spin the model to see the completed chamfer feature.
   - Save your model
Until now, you have used only **CTRL + D** to reorient your model. This time you will select named views from the Graphics toolbar:

9. Click **Named Views** from the Graphics toolbar, then scroll down and select **TRIMETRIC** from the drop-down menu.

![Image of TRIMETRIC named view]

10. Click **Named Views** and select **Standard Orientation** from the drop-down menu.

11. Saving your work and closing open windows from the Quick Access toolbar:
   - Click **Save** to save your work.
   - Click **Close Window** as many times as are required to close any open windows.

![Image of model with closed windows]

**What have you learned?**

- Engineering feature – Chamfer.
- Chamfer dashboard – width (D x D).
- Selecting edge references – individual, adding reference edges with CTRL key.
- Rotating the model.
- Edit Definition to re-open and edit existing features.
- Saving the model.
Module 2
Procedure – Part modeling - Strut

Scenario
Connecting the corner cubes will be struts with pegs at each end that fit into the holes in the corner cubes.

The kit is based on 100 mm spacing between cube centers. A strut length of 90mm provides clearance in the center of the cubes.

After creating a new part, you will sketch a small circle at the center of the strut and extrude this on both sides of the sketch to form the pegs. A larger circle, also located in the center of the strut, is extruded on both sides to form the shouldered section. Finally, a revolved arc cuts material from the strut to create the narrowed center section.
Step 1: Set working directory and create a new part.

If you just completed Module 1 and have not exited from Creo Parametric, you should skip tasks 1 and 2.

1. Start Creo Parametric.
2. Setting the working directory:
   - Click Select Working Directory from the Data group of the Home tab.
   - In the Select Working Directory dialog box, browse into the folder where you saved the Corner Cube model.
   - After you have browsed into the working directory folder, click OK to set that folder as your working directory.

The Strut part you create will be saved to and opened from this “working directory”, the same folder where your Corner Cube was saved.

3. Creating the new strut part model:
   - From the Quick Access toolbar or Home tab, click New.
   - Type STRUT_100 in the Name field and click OK.
   - You cannot use spaces in filenames so use underscores or hyphens instead.

4. Changing the display of datum features:
   - In the Graphics toolbar, disable the display of all datum features except datum planes.
What have you learned?

- Setting the working directory.
- Create and name a new part
- Datum display – visibility
Step 2: Start an Extrude

You will start an Extrude choosing datum plane RIGHT as the sketch plane.

1. Starting an Extrude feature and defining the sketch plane:
   - Start the Extrude tool from the Shapes group.
   - In the model tree or graphics area, select datum plane RIGHT.

The Sketch tab will open and you will be able to start sketching. Notice the two “Reference” lines will be visible linked to datum planes FRONT and TOP.

What have you learned?

- Starting an extrude feature.
- Selecting a sketch plane.
- Ribbon menu workflow.
Step 3: Create a sketch to define the peg diameter

An 8 mm diameter circle will be sketched on datum plane RIGHT. The center of the circle will be located at the intersection of the horizontal and vertical sketch references. This sketch will be created in the 3D view, without reorienting to the 2D sketch view.

1. Sketching a circle:
   - In the Sketch tab, click **Center and Point** circle.
   - Move the cursor over the intersection of the two reference lines **X1**, when the cursor snaps to the intersection, click to place the center of the circle.
   - Move the cursor away from the center and click **X2** to complete the circle.
   - Middle-click in the graphics area to deselect the circle tool.

2. Changing the circle diameter:
   - Double-click the diameter dimension value at **X1**, then type 8 and press **ENTER**.
Depending on how large your circle was first sketched, the resized circle may appear very small within the graphics area. This is common for the first sketch created in a new model and as you will see, it is nothing to worry about.

3. Refitting the sketch in the graphics area.
   - In the Graphics toolbar click **Refit** to refit the sketch within the graphics area.

4. Click **OK** from the **Close** group of the **Sketch** tab to complete the sketch and return to the Extrude dashboard.

**What have you learned?**

- Sketch – Center and Point circle.
- Dimensions – Changing value.
- Refit model to fit graphics window.
Step 4: Complete the Extrude that defines the length of the strut

You will now edit the depth of the Extrude to be 90, symmetrical on both sides of the sketch plane.

1. Making changes to the extrude using the dashboard:
   - Click *Blind* and then select *Extrude on both sides* from the depth dropdown menu (shown as *X1*).
   - Click in the depth field *X2*, type 90 and press *ENTER*.
   - Click *Complete Feature* from the dashboard to complete the extrude.

2. Saving your work:
   - In the Quick Access toolbar, click *Save*.
   - In the Save Object dialog, click *OK* to specify that the model will be saved to your working directory.

What have you learned?

- Extrude - sketch based feature, extrude on both sides.
- Dashboard interface.
- Saving the current model to the working directory.
Step 5: Extrude shoulder geometry

You will use the same technique used in Steps 2 - 4 to extrude a 12 mm diameter circle sketched on the datum plane RIGHT. This feature will have a depth of 70 mm, extruded on both sides of the sketch plane. This will form the shoulder of the strut.

1. If necessary, enable the display of datum planes.

2. Reorienting the model to its default orientation:
   - Press CTRL + D.

3. Starting an Extrude feature and defining the sketch plane:
   - Start the Extrude tool from the Shapes group.
   - In the Model Tree or graphics area, click to select datum plane RIGHT as the sketch plane.

4. With the Sketch tab now open, begin sketching a circle:
   - In the Sketch tab, click Center and Point circle.
   - Move the cursor over the intersection of the two reference lines X1, when the cursor snaps to the intersection, click to place the center of the circle.
   - Move the cursor away from the center and click X2 to complete the circle.
   - Middle-click in the graphics area to deselect the circle tool.
5. Changing the circle diameter:
   • Double-click the diameter dimension value at \textit{X1}, then type \textit{12} and press \textit{ENTER}.

6. Completing the sketch:
   • Click \textbf{OK} from the Close group of the Sketch tab.

7. Disable the display of datum planes.

8. Defining the extrude to form the shoulder of the strut:

   \begin{itemize}
   \item By default, Creo Parametric displays a preview of the extruded circle adding material to the right of the sketch plane. You will now use options in the dashboard to make the feature extrude 70 mm on both sides of the sketch plane.
   \end{itemize}

   • Select \textbf{Extrude on both sides} from the depth drop-down menu (shown as \textit{X1}).
   • Click in the depth field \textit{X2}, type \textit{70} and press \textit{ENTER}. 
• Click **Complete Feature**.

9. Click **Save** to save your work.

### What have you learned?

- Datum display – visibility.
- Viewing the model – default and spin.
- Extrude - sketch based feature, extrude on both sides.
- Sketch geometry – circle and change dimension.
- Dashboard interface.
- Saving the current model.
Step 6: Revolve a sketched arc to thin the center of the strut

You will use a Revolve feature with an arc sketch drawn on the FRONT datum plane to remove material around the center of the strut. This will make the strut lighter and reduce the amount of material being used.

1. If necessary, disable the display of all datum features.

2. Starting a Revolve (sketch based) feature and defining the sketch plane:
   - Start the Revolve tool from the Shapes group. Notice the Revolve dashboard and the revolve options.
   - In the model tree, click to select datum plane FRONT as the sketch plane.
   - In the Graphics toolbar, click Sketch View to reorient the sketch plane parallel to the screen.

The model space will rotate until the sketch plane is parallel to the computer screen.
The sketch you will be creating must be snapped to the top silhouette edge of the strut. To do this, you will create geometry references on-the-fly, using the ALT key.

3. Starting an arc:
   - In the Sketch tab, from the arc types drop-down menu, select **Center and Ends**.
   - Move the cursor until it snaps to a point X1 on the vertical reference above the strut. Click to place the center of the arc.

   - Move the cursor away from the center and you will see a construction circle previewing the size of the arc you are creating.
   - With the cursor over the top horizontal edge of the strut at X2, press the **ALT** key and click.
   - Release the ALT key and a light blue dashed reference line will appear along the top edge of the strut.
   - With the cursor over the reference line, also at X2, click to locate the start point of the arc.
   - Move the cursor to the right and click on the reference at X3 to locate the endpoint of the arc.
   - Middle-click in the graphics area to deselect the arc tool.
You will now resize the arc using the mouse and then use the **Normal Dimension** tool to manage dimensions to match your design intent shown below.

5. Dragging the arc to resize it:
   - Click to select and drag the arc until it is above the horizontal reference line as shown by X1, then release the mouse button to place the resized arc.
6. Dimensioning the arc:
   - If necessary, zoom in closer to the arc.
   - From the Dimension group, click **Normal Dimension**.
   - Click to select the horizontal reference line at X1 in the illustration below.
   - Click the arc at X2.
   - Middle-click at X3 to place the dimension value.
   - Type 4 and press **ENTER**.

   ![Dimensioned Sketch](image)

   - With the **Normal Dimension** still active, click the end of the arc shown at X1.
   - Click the other end of the arc X2.
   - Middle-click at X3 to place the dimension value.
   - Type 60 and press **ENTER**.
   - Middle-click to release the dimension tool.

   ![Dimensioned Sketch](image)

   The dimensioned sketch should look like this.
As well as a sketched profile, a revolve requires an axis of revolution. You will sketch a geometry Centerline to define the axis of revolution.

7. Adding a geometry center line:

- In the Datum group of the Sketch tab, click the **Centerline** tool.

  **Make sure you select the centerline tool from the Datum group, not the Sketching group.**

- Click on the horizontal reference at **X1** to start the centerline and at **X2** to end it. Be sure both are snapped to the horizontal reference.

- Press **CTRL + D** to reorient the model to its default orientation.

- Click **OK** to complete the sketch and return to the Revolve dashboard.

The preview of the feature shows the dimension defining the revolve feature as 360 degrees around the axis of rotation.

8. Editing the Revolve feature to remove material from the strut:

- Make sure the **Revolve as solid (X1)** option is selected in the dashboard.

- Click to enable the **Remove Material X2** option from the dashboard.

  Material will be removed from the side of the sketch shown by the **purple** material.
direction arrow.

- Click **Complete Feature**.

9. Click **Save** to save your work.

**What have you learned?**

- Datum display – visibility.
- Viewing the model – default, perpendicular to the sketch plane.
- Sketch – Adding new references on the fly.
- Sketch geometry – arc, geometry centerlines, drag geometry.
- Sketch dimensions – editing, adding new.
- Revolve - sketch based feature, profile and a centerline.
- Revolve dashboard – revolving as a solid, remove material.
- Saving the current model.
Step 7: Round edges of the strut

Rounds are “Engineering” features and are applied to edges of the model. You will add 0.5 mm radius rounds to the shoulders of the strut. This will make it smoother for handling and help with injection molding.

1. Hiding the display of datum features.
   • If necessary, disable the display of all datum features and press CTRL + D to return the model to its default orientation.

2. Starting the Round feature.
   • From the Engineering group, start the Round tool.

3. Defining the radius of the round:
   • In the dashboard, edit radius X1 to be 0.5 and press ENTER.

4. Selecting the edges to round:
   • Select one of the edges shown in green.
   • Hold down the CTRL key and select the other edge shown in green.
   • Click Complete feature to complete the round.

5. Saving your work:
   • If necessary, press CTRL + D to reorient the model to its default orientation.
   • Click Save to save your work.
What have you learned?

- Engineering feature – Round.
- Round dashboard – setting the radius.
- Selecting edge references – individual, adding reference edges using CTRL key.
- Saving the model.
Step 8: Chamfer the ends of the strut

Like rounds, chamfers are also “Engineering” features and are applied to edges of the model. You will add 0.5 mm chamfer to the both ends of the strut. This will make it easier to insert the strut ends into the holes of the cubes.

1. Start the Chamfer tool from the Engineering group of the Model tab.
   • Notice the Chamfer dashboard and its specific options.
2. Defining the size of the chamfer:
   • In the dashboard, edit the size of the chamfer width to be 0.5 and press ENTER.

3. Selecting edges to chamfer:
   • Select one of the edges shown in green.
   • Press CTRL and select the other edge shown in green.
   • Click Complete feature.

4. Saving your work:
   • If necessary, press CTRL + D to reorient the model to its default orientation.
   • Click Save to save your work.
What have you learned?

- Engineering feature – Chamfer.
- Chamfer dashboard – setting the width (D x D).
- Selecting edge references – individual, adding reference edges using CTRL key.
- Saving the model.
Module 3

Procedure – Assembly

Scenario

This section will teach you how to put the components you have created together into an assembly.

You will start by creating a new assembly file. In the new assembly, you will first assemble a corner cube to the default location. Struts are then assembled into holes in the cube.

Once you have struts in place, additional cubes and struts can be added to the assembly.

Step 1: Set working directory and create a new assembly

If you just completed Module 2 and have not exited from Creo Parametric, you should skip tasks 1 and 2 below.

1. Start Creo Parametric.
2. Setting the working directory:
   - Click Select Working Directory from the Data group of the Home tab.
   - In the Select Working Directory dialog box, browse into the folder where you saved the Corner Cube and Strut models.
   - After you have browsed into the working directory folder, click OK to set that folder as your working directory.
The assembly file you create will be saved to and opened from this “working directory”, the same folder where your Corner Cube and Strut were saved.

3. Creating the new assembly model:
   • From the Quick Access toolbar or Home tab, click New.
   • In the New dialog box, click to select Assembly as the new model type.
   • Type KIT_ASSEMBLY in the Name field and click OK.

4. Changing the display of datum features:
   • In the Graphics toolbar, disable the display of all datum features except coordinate systems.

Coordinate systems will be used to assemble the first component.

The default coordinate system should be displayed at the center of the graphics area. Notice the X, Y and Z axes of the coordinate system.

What have you learned?

- Set working directory – an existing folder.
- Create a new assembly.
- Datum display – visibility.
Step 2: Adding the first component to the assembly

The first component you will add to the assembly is a corner cube part. The cube should be positioned using the **Default** constraint type. This will place the cube at the center of the assembly and make it a stable reference that other components can be assembled to.

1. **Selecting the component to assemble:**
   - Click **Assemble** from the **Component** group of the **Model** tab.
   - In the Open dialog box:
     - Select the **CORNER_CUBE.PRT** model.
     - In the lower-right corner of the dialog box, click to expand the **Preview** pane.
     - Click **Open** to assemble this component.
The part will be attached to the cursor and the Assembly dashboard will open.

2. Locating the part temporarily, before final placement:
   • **Move** the cursor to position the corner cube just to the left of the assembly coordinate system, then **click** in the graphics area to place it temporarily.

   ![At the center of the corner cube, you will see the 3D Dragger.](image)

Later, when placing components, you will use the 3D Dragger to position the component close to its final destination.

3. Adding assembly constraints:
   • In the Assembly dashboard, click **Automatic** and select **Default** from the drop-down menu.
The corner cube will move until its XYZ coordinate system coincides with the assembly's default coordinate system.

Components change to a **yellow-orange** color as soon as they become fully constrained (cannot move) in the assembly.

The Assembly dashboard shows the **Default** constraint type message confirms the part is **Fully Constrained**.

4. Complete the placement of the part:
   - In the Assembly dashboard, click **Complete Component** to complete the component placement.

5. Click **Save** to save then **OK** to close the Save dialog.

**What have you learned?**

- Adding a component to an assembly – temporary placement.
- Assembly dashboard – status, fully constrained.
- Assembly constraints – Automatic, default, fully constrained.
- Datum display – visibility.
Step 3: Add the first strut to the assembly

The second part you will add is a strut. You will position the strut by inserting the peg at the end of the strut into a hole in the cube. Then you will mate the shoulder surface to the cube. This exactly replicates how you would assemble a real strut and cube.

1. Disable the display of all datum features.

2. Selecting the component to assemble:

   - Click **Assemble** from the Component group of the Model tab.
   - In the Open dialog box:
     - Select the **STRUT_100.PRT** model.
     - Click **Open** to assemble this component.
The part will be attached to the cursor and the Assembly dashboard will open.

3. Locating the part temporarily, before final placement:
   • Move the mouse cursor until the strut is positioned just to the right of the cube, then click in the graphics area to place it.

   If you mistakenly middle-click but do not hold down the middle-mouse button and move the mouse, the dashboard will close and the component placement will be prematurely completed. To re-open the dashboard and continue constraining the component, right-click the component in the Model Tree and select Edit Definition from the pop-up menu. Engineers use many shortcuts to speed up their work and middle-click is one that closes the dashboard!
By default, the **Automatic** option is used to place components in a Creo Parametric assembly. The constraint type used is then based on the geometry selected and the component location or orientation. To help with this process, try to position the component being assembled as close as you can to its final position. In the case of the strut, place it close to the hole it will be inserted into.

4. Adding the first assembly constraint:
   - Move the cursor over the cylindrical surface of the strut shown as X1.
   - When the cylindrical surface of the strut pre-highlights, click to select it.
   - Move the cursor over the cylindrical surface of the hole in the corner cube model, shown as X2.
   - When the cylindrical surface of the hole pre-highlights, click to select it.

Creo Parametric recognized the two cylindrical surfaces and applied a **Coincident** constraint to them. The strut should move until the peg is in-line with the hole and a Coincident constraint label is displayed on the model.

Notice only one of the arrows and one of the circles in the 3D dragger is now colored. These are the only directions the strut can now move in the assembly.
5. Adding a second assembly constraint:
   • Click to select the flat surface of the cube that is closest to and facing the strut X1.
   • Press and hold the middle-mouse button and drag to spin the model until you can see the flat surface shown as X2 on the strut.
   • Click to select the flat surface shown as X2.

Creo Parametric recognizes two flat surfaces facing each other and applies a **Coincident** constraint. The two selected surface are now touching each other.

The strut has changed to a **yellow-orange** color indicating that its position is fully constrained in the assembly.
The Assembly dashboard shows the **Coincident** constraint type was the last used and that the strut is now **Fully Constrained**.

- Click to open the **Placement** tab X1 at the left of the dashboard.

Notice in the Placement tab that two **Coincident** constraints were used to position the strut.

Typically three constraints are needed to fully constrain a component in an assembly. However, if two cylindrical surfaces or axis are made **Coincident**, the **Allow Assumptions** option X2 is enabled and when checked/ticked, prevents the component rotating about the coincident axis.

- Click **Complete Component** to complete the component placement.
- The strut returns to its original gray color.
- Reorienting and saving your work:
  - Press **CTRL + D** to reorient the model.
  - Click **Save** to retain the changes in the assembly.
What have you learned?

- Datum display – visibility.
- Adding a component to an assembly – temporary placement.
- Component placement – adding constraints, coincident.
- Model tree – Edit Definition to re-open and edit existing features.
- Assembly dashboard – status, fully constrained.
- Assembly constraints – Automatic, coincident and allow assumptions
- Saving the current model.
Step 4: Applying colors and textures to the parts

Creo Parametric lets you apply appearances to your model that represent a wide range of colors, textures, transparency and lighting. A library of predefined appearances represent many standard materials but you can also create your own. You will now apply appearances to the parts you created.

1. If necessary, set the working directory then open the **KIT_ASSEMBLY.ASM** model.

2. Opening the corner cube part from the assembly:
   - In the model tree, right-click **CORNER_CUBE.PRT** and select **Open** from the pop-up menu.

The corner cube part will open in a new Creo Parametric window.

3. Applying an appearance to the part:
   - Click to open the **Render** tab.
   - Click the **Appearance Gallery** text X1, just below the gray appearance ball.
   - In the My Appearances section of the dialog box, scroll X2 through the color balls until you find a color you would like to apply.
   - Click to select the color X3 you want applied to the model.

TheAppearances Gallery will close and, when the cursor is in the graphics window, it will change to a paint brush.

   - Move the mouse into the model tree and click the part name **CORNER_CUBE.PRT**; this will select the entire part.
   - Click **OK** in the **Select** dialog box or middle-click in the graphics area to apply the appearance.
The new appearance is now applied to the part.

4. Saving and closing your model:
   - Click **Save** to save your work.
   - Click **Close Window** from the **Quick Access** toolbar.

   The window containing the cube will close, leaving the assembly window active with the colored corner cube.

5. Applying an appearance to the part:
   - Repeat the process, applying a different colored texture to the strut part.

6. Click **Close Window** from the Quick Access tool.

   Notice that because Creo Parametric assemblies are associative, the new appearances are immediately displayed in the assembly. A change anywhere is seen everywhere.

---

**What have you learned?**

- Opening/closing a part from an assembly.
- Applying textures – Applying a default color appearance to a part.
- Saving and closing the current model.
Step 5: Assembling more struts

1. Selecting the component to assemble:

   - Click **Assemble** from the **Component** group.
   - In the Open dialog box, double-click the **STRUT_100.PRT** model.

Notice in the dashboard that **Place Using Interface** has been enabled and a temporary interface named **TMP_INTFC001** is selected. This means that Creo Parametric remembers the references that were selected the first time the strut was inserted into the assembly. This time you will only have to select the assembly geometry. You can see that the cylindrical surface of the strut is already selected.

2. Locating the strut temporarily and determining which end of the strut references the second coincident constraint:

   - Move your mouse to locate the strut above the assembly and click in the graphics area to place it temporarily.
   - Move your cursor over the **Coincident** constraint tag **X1**, the surface that is referenced by this constraint will highlight on the strut model.

Also notice that the **Coincident** constraint tag is pointing to one end of the strut. Remember which end of the strut is highlighted, you will need to know this in the task below.
3. Before selecting assembly references, use the 3D dragger to reorient the strut:
   - Click and drag the blue ring of the 3D Dragger so that the end of the strut with the *Coincident constraint tag is facing down.
   - Click and drag near the small sphere at the center of the 3D Copilot to move the strut above the corner cube.

   **How the 3D Dragger works:**
   - Dragging an arrow moves the model along the axis of the arrow.
   - Dragging a circle rotates the model about the axis of the same colored arrow.
   - Dragging the small sphere at the center will drag the model in the plane of the screen.

4. Selecting assembly references from the corner cube:
   - Click to select the cylindrical surface of the hole X1 on the corner cube.
   The strut will shift slightly to make the two cylindrical surfaces coincident.

   - Click to select the top flat surface of the corner cube X2.
   The strut will move until the shoulder of the strut is coincident with the top of the cube and it will change to a **yellow-orange** color, indicating that it is fully constrained.
5. Click **Complete Component** to complete the placement of the second strut and add a new entry to the model tree.

The assembly now has one corner cube and two struts.
- Continue adding struts and corners to create a larger assembly.

You do not have to create the same assembly as shown here.

Make sure you build your model the “correct way up”. This helps with rendering later. Check by selecting default, isometric or trimetric view.

You may find it useful to use **Flip** from the **Placement** tab in order to flip the orientation of a constraint.

**Before Flip**

**After Flip**
Use care to select the correct references. For example, if you select an edge rather than surface when constraining the parts of your assembly, you will have problems.

6. Click **Save** to save your work.

**What have you learned?**

- Assembly - adding a component, temporary placement.
- Assembly – Placement using constraints and fully constrained.
- Assembly – Placement using Interface when adding identical components.
- Assembly – 3D Dragger to re-position the part
- Assembly - Selecting surfaces
- Saving the current model.
Module 4
Procedure - Rendering

Scenario
This section will teach you how to create a photo-realistic image of your model. This process is often called rendering.

You will start by applying a “Scene” to your model which includes details of the room, lighting and any special effects.

Creo Parametric uses these settings and calculates the light paths to create the finished image.

Step 1: Open the Render tab and apply a scene

If you just completed Module 3 and have not exited from Creo Parametric, you should skip tasks 1 to 4 below.

1. Start Creo Parametric.
2. Setting the working directory:
   - Click Select Working Directory from the Data group of the Home tab.
   - In the Select Working Directory dialog box, browse into the folder where you saved the other Primer models.
   - After you have browsed into the working directory folder, click OK to set that folder as your working directory.
3. Open your assembly:
   - Click Open from the Quick Access toolbar or Home tab.
   - From the File Open dialog box, double-click your assembly to open it.
4. If necessary, disable the display of all datum features.

5. Reorient the assembly using the mouse or by selecting a saved view:
   - Press **CTRL + D** to reorient the model
   - or
   - Click **Named Views** from the Graphics toolbar and from the list select **TRIMETRIC**.
     The model should look as shown on the right.

   If you ISOMETRIC and TRIMETRIC are missing from your named view list, your installation of Creo Parametric has not been configured using the standard PTC Education templates. You can still zoom and spin your model into any orientation you want.

Next, you will apply one of the default scenes and corresponding room to your model. You will then snap the floor of the room to the bottom of the assembly.

6. Opening the Render tab:
   - In the Quick Access toolbar, click the **Render** tab.
7. Applying a scene:

- Click on Scene to open the Scenes dialog box.
- Scroll through the list of scenes then double click on Photolux-Studio_Hard to apply it to your model.
- Check/tick the Save scene with model option.
- In the Scenes dialog box, click on the Room tab.

- In the Room Size section, click at X1 to align the floor with the bottom of your assembly.
- Click Close to finish making changes to the Scene settings.
What have you learned?

- Setting working directory – existing folder.
- Opening an existing model.
- Named Views – trimetric and isometric.
- Render tab – Scenes tool.
- Scenes – applying to model, floor position, save with model.
Step 2: Draft render

Draft render will let you see whether the changes you made to the Scene settings are giving you the desired effect. Draft render doesn’t take long and gives you the opportunity to go back and quickly try out other scenes and settings.

1. **Draft render:**
   - In the Render tab, click on **Render Window** to perform a Draft render.
   - There will be a short wait with progress reported in the Render Abort dialog box.

When the draft render finishes, the graphics area will display a grainy image representing the effects you have applied.

   - If you are not happy with the way your model looks, try applying a different scene.
   - Once you are happy with the draft render you can continue to refine the quality of the render.

2. Click **Save** to save your work.

Each time you change the scene you also need to snap the floor to the model before trying the render.

**What have you learned?**

- Draft render.
- Scenes – Applying a new scene, saving with model, positioning the floor.
Step 3: Adding perspective

Perspective adds realism to the render by reducing the apparent size of objects as they get further away. An understanding of photography and illustration can help achieve the results you want.

1. Apply perspective:
   - In the Render tab, start the **Perspective View** tool.
     A default value for perspective will be applied. You will probably want to adjust the amount of perspective.
   - In the Perspective group of the Render tab, click on **Perspective** to open the perspective dialog box.
   - Use the **Eye distance** slider combined with zooming and spinning until you see the amount of perspective you want.

2. Click **OK** to close the Perspective dialog box.

Below is an example render using Draft quality and Perspective.

What have you learned?

- Perspective – applying to the model, adjusting.
Step 4: Render setup

Render setup contains many options including the quality of the image. You will increase the quality from the default Draft setting to Maximum.

1. Render setup

   • From the Setup group of the Render tab, start the **Render Setup** tool.
   • In the Render Setup dialog, change the **Quality** setting to **Maximum**.
   • Look at the options under each of the tabs to see the wide range of settings Creo Parametric provides.
   • Leave the other settings as defaults and click **Close**.

What have you learned?

   • Render quality settings
   • Brief glimpse of available settings.
Step 5: Final render

1. Final render
   - Make sure your model is in the right position.
   - In the Render tab, click on Render Window 🔄 to perform the final render.

The render may take some time especially on slower computers. Creo Parametric is doing a great deal of mathematical calculation to work out light paths, shadows and multiple reflections.

During the render process you may see the resolution improve a section at a time. This is a clue to the mathematical algorithms and iterative calculations being carried out.

The final render should look quite realistic even with the default settings.

The level of realism is only limited by the users understanding of space, form, light, texture, and how to adjust the settings in Creo Parametric.

In the example below, additional objects have been added to create a context for the gearbox adding greatly to the realism of the scene.

2. Click Save 📋 to save your work.

What have you learned?

- Final render.
- Setting the context for render.
Module 5

Procedure - Engineering drawing

Scenario

The final section of this introductory tutorial teaches you how to create an engineering drawing from a Creo Parametric model.

This process is largely automated and, because models and drawings are “associative”, changes to the model are immediately reflected in the drawing.

Configuring Creo

PTC provides a number of bat files to easily configure Creo Parametric so that it defaults to the units and drawings standards in your region. The bat files together with instructions how to use them are located here:

C:\Program Files\PTC\Creo 2.0\Common Files\F000\creo_standards

F000 indicates the software build code and your installation may have an M prefix.

The drawing section of this tutorial uses the configure_for_ISO_mmks.bat file setting millimeters, kilograms and seconds as the units and ISO drawing standards.
Step 1: Set working directory and open cube corner

If you just completed Module 4 and have not exited from Creo Parametric, tasks 1-2 below do not need to be performed, please skip to Step 3.

1. Start Creo Parametric:

2. Setting the working directory:
   - Click **Select Working Directory** from the **Data** group of the **Home** tab.
   - In the Select Working Directory dialog box, browse into the folder where you saved the other Primer models.
   - After you have browsed into the working directory folder, click **OK** to set that folder as your working directory.

3. Open the Corner Cube:
   - Click **Open** from the Quick Access toolbar or Home tab.
   - From the File Open dialog box, double-click **corner_cube.prt** to open it.
Step 2: New engineering drawing

Drawing templates in Creo Parametric will use the part open on screen as the basis for an engineering drawing. The A3/B size templates automatically create a border, title block, three orthographic views and a pictorial representation! Dimensions are easily imported from the 3D model and annotations added.

1. Starting a new drawing:
   - In the Quick Access toolbar, click **New** to start a new file.
   - In the New dialog box, click to select **Drawing** as the model type.
   - Type **Corner_cube** in the **Name** field then click **OK**.
     - In the Template section, select which size drawing you would like to use and click **OK**. In this example, we have chosen **a3_drawing**.

Depending which template you select, you will see slightly different arrangements of views.
For example the **a4_drawing** template has only two orthographic views.
The template has saved you a great deal of work by creating borders, title blocks and the different views. Typical changes you may want to make include the scale of the drawing and adding dimensions and annotations.

- Click **Save** to save your work.

**What have you learned?**

- Opening an existing component.
- Starting a new drawing - paper size and template.
- Template – borders, title blocks and views.
Step 3: Changing the drawing scale

Automatic creation of the drawing will have chosen a scale to match the size of the model to the paper size. The scale is displayed below the drawing.

1. Changing the drawing scale:
   - At the bottom left corner of the drawing screen, double click on **SCALE: 1:1**.
   - In the Scale dialog at the top of the graphics area, enter a value for scale and click **Accept Value** to apply the new scale to the drawing.
You should always choose a scale that would be listed in a national or international standard. If Creo Parametric does not change the scale, try a different value.

What have you learned?

- Drawing scale – changing the scale.
Step 4: Moving views

By default, views are locked in position and will need to be unlocked before they can be moved.

1. Unlocking a view:
   - In the drawing, click on the lower left view to select it. The view border will turn green to show it is selected.
   - Right click and pause, from the pop-up menu, select Lock view movement to allow the view to move.

2. Moving a view:
   - Click and drag the view to a new location.

If you are dragging the front view, you should see the other “projected” views move to keep them orthogonal as you drag.

   - When you have finished moving the views you can lock them again by repeating step 1.

What have you learned?

   - Drawing views – unlocking, moving, locking.
Step 5: Adding dimensions

There are two ways to add dimensions to a drawing.

You can “show” the dimensions used to create features in the 3D model. These have the advantage of being able to change the 3D model if they are altered in the drawing.

“Added” or “driven” dimensions can be inserted into a drawing. These report the size of the model and will update if the model changes but this type of dimension cannot be used to control the 3D model.

1. Showing dimensions:
   - In the graphics area, select the view you want to add dimensions to. The border of the sketch will turn green showing it is selected.
   - In the Annotations group in the Annotate tab, click on Show Model Annotations.

   The Show Model Annotations dialog box will open listing all the dimensions that were used to create the 3D model of the corner cube. The dimensions will also appear on the selected view colored dark red.

   The dimensions can be checked/ticked individually in the dialog to make them appear on the drawing. Selected dimensions turn blue to show they will appear in the drawing. Near the bottom of the dialog box is a button to add all the dimensions.

   - Click to show all dimensions on the selected view.
   - Click OK to close the dialog.
2. Moving dimensions:
   - Click away from the model views to cancel any selections.
   - Click to select the text for one of the dimensions. The text will turn green to show it is selected.
   - Click and drag the selected text to a new location.

   Here the 8 mm diameter has been moved to the side of the view.

3. Deleting dimensions:
   Near the top of the cube there is a 0.5 mm chamfer dimension. This dimension will be noted in a comment so is not required in this view.
     - Click to select the dimension then press Delete on the keyboard.

   The dimension is removed from the drawing but will remain in the 3D model.

4. Moving dimensions to a different view:
   - Click to select the hole diameter below the front view.
   - Right click on the selected text and pause, from the pop-up menu, click Move item to View.
   - Click on the projected view above the current view to move the dimension.
   - Drag the diameter into a suitable position.

   The drawing below has all the dimensions rearranged.
• Click **Save** to save your work.

### What have you learned?

- Drawing dimensions – overview, showing, adding.
- Showing dimensions on a drawing view.
- Moving dimensions to another view.
- Dimensions – Repositioning text, deleting.
Step 6: Adding annotations

Annotations will complete this basic drawing. You will add your school name to the title block.

1. Adding annotation text:
   - In the Annotations tab, Annotations group, start the Note tool.
   - Keep all of the defaults in the Menu Manager.
   - At the bottom of the Menu Manager, click Make Note at X1.
   - Click at X2 in the middle of the large empty cell in the title block to set the location for the note.
   - In the Enter Note text entry dialog box, type the name of your school. If you want a second line of text click Accept Value or press ENTER on the keyboard.
   - When you have finished typing the text you want to appear, click Accept Value twice or, press ENTER twice to place the text.
   - Click on Done/Return at X3 to close the Menu Manager.
   - Select the new text and move it into position.
2. Edit annotation text:
   • Click to select the text. A green rectangle surrounds the text to show it is selected.
   • Right click on the text and, from the pop-up menu, select Properties.
   • You can edit the text in the Text tab in the Note Properties dialog box.
   • Click on the Text Style tab to see other parameters you can change.
   • Click OK to close the dialog box.
3. Click Save 🗄️ to save your work.

What have you learned?
   • Adding annotations - Note.
   • Note text – positioning, adding text, moving, editing and formatting.
Module 6

Extension task

Teachers around the world can get a school license for Creo Parametric online at http://www.ptcschools.com/

Creating new components for the kit is a great way to practice your new skills with Creo Parametric. Below are some suggestions but you will probably have ideas of your own.

Another great way to learn Creo Parametric is to model everyday objects.

Just like learning a new language or playing a musical instrument, practice is the key to becoming proficient!

We hope you enjoy using Creo Parametric.

Teachers in the following regions are able to access face to face training and expected to complete a modelling task before they are issued with a school license for Creo Parametric.

UK – http://www.ptcschools.com/
Australia - nobbya@tpg.com.au
New Zealand - h.morris@auckland.ac.nz